The Nissan Path Forum Index The Nissan Path
The World Wide Nissan Pathfinder Owner's Forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Use Google to search TheNissanPath forums ->
Cruise Control Blinking and not setting. Not swithes

 
Post new topic   Reply to topic    The Nissan Path Forum Index -> R51 Electrical
View previous topic :: View next topic  
Author Message
jlwardn



Joined: 20 Dec 2010
Posts: 65
Location: West Michigan

PostPosted: Thu Feb 01, 2018 2:11 pm    Post subject: Cruise Control Blinking and not setting. Not swithes Reply with quote

I have a 2010 Nissan Pathfinder LE that the cruise control is blinking when I turn it on and try to set it. I have searched and found many people saying to replace the switch at the brake pedal. I did that and it did not fix it. I then ordered the switches in the steering wheel. The Nissan dealer then sent me the switch for the brake pedal. I called them and they were confused. They actually sent me the switch for the brake lights the first time and I did not really know better and replaced that one. Anyway I replaced the cruise brake switch and still not working. Today I just replaced the switches in the steering wheel. It seemed to work perfect until I turned the wheel like doing a U-turn. Then it started blinking. I used scanner to reset code and it did it again when turning the wheel to the right but not to the left. Now the airbag light came on. Not only is the airbag light blinking but the radio controls and horn no longer work. I am guessing I now have to replace the clock spring? WTF. I don't want to spend another $200 on a guess. I already have $200 into the two brake switches and the wheel cruise switches. Any ideas?
_________________
2005 Pathfinder LE 4x4
Removed Running Boards, Removed middle seat, 35w HID LOWs/55w HID Highs, Kenwood DDX8120

PAST NISSANS:
2008 Pathfinder LE
2005 Pathfinder LE
2002 Pathfinder SE 1996 Maxima GLE (x2)
2000 Xterra SE 1994 Altima GXE
1995 Kingcab 4x4 1986 300ZX
1986.5 Kingcab 4x4
Back to top
View user's profile Send private message
smj999smj
Moderator


Joined: 22 Jan 2012
Posts: 4746
Location: Prospect, VA

PostPosted: Thu Feb 01, 2018 5:26 pm    Post subject: Reply with quote

From the EC section of the FSM:

When the ECM detects any of the following conditions, the ECM will cancel the cruise operation and inform
the driver by blinking indicator lamp.
>Engine coolant temperature is slightly higher than the normal operating temperature, CRUISE lamp may
blink slowly.
When the engine coolant temperature decreases to the normal operating temperature, CRUISE lamp will
stop blinking and the cruise operation will be able to work by depressing SET/COAST switch or RESUME/
ACCELERATE switch.
>Malfunction for some self-diagnoses regarding ASCD control: SET lamp will blink quickly.


It would probably be a good idea to download the Engine Control chapter of the factory service manual for your vehicle, which you can find in the knowledge base at NissanHelp.com. It will give you system information and component tests procedures.
_________________
2006 Pathfinder LE VQ40DE AWD, Nitto Dura Grappler P265/65R17, aftermarket radiator, Airlift 1000's, Bilstein HD rear shocks
Back to top
View user's profile Send private message Send e-mail
Mr R51-07



Joined: 16 Feb 2018
Posts: 3

PostPosted: Sun Aug 19, 2018 6:52 am    Post subject: Reply with quote

I had this problem on our 2007 Pathfinder, would turn on the cruise and the "SET" light would start blinking rapidly. Turned out to be a loose battery connection. Tightened up the cables on the battery and it now works fine.
Back to top
View user's profile Send private message
VK56LE



Joined: 15 Aug 2018
Posts: 6
Location: Tampa

PostPosted: Sun Aug 19, 2018 9:04 am    Post subject: Reply with quote

Your clockspring may be wearing out. I just had to replace mine. Unfortunately they dont sell just the clockspring but the whole combination switch assembly. Common symptoms are your switches on the steering wheel not working all the time and possible airbag light on with the drivers airbag code like what I had. Ten minute fix but mine was around $200.



Back to top
View user's profile Send private message
Mr R51-07



Joined: 16 Feb 2018
Posts: 3

PostPosted: Sun Sep 02, 2018 5:46 am    Post subject: Reply with quote

Unfortunately that wasn't the fix and it was just coincidence that it worked for a couple days after that. It did turn out to be the Spiral Cable, replaced it and everything works perfect again.

Got mine from Courtesy Parts, it was $224
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Nissan Path Forum Index -> R51 Electrical All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group