The Nissan Path Forum Index The Nissan Path
The World Wide Nissan Pathfinder Owner's Forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Use Google to search TheNissanPath forums ->
Nissan Terrano 110 PS - Loss of power issue

 
Post new topic   Reply to topic    The Nissan Path Forum Index -> General Automotive
View previous topic :: View next topic  
Author Message
JesseVoss



Joined: 08 May 2018
Posts: 12

PostPosted: Wed May 09, 2018 7:46 pm    Post subject: Nissan Terrano 110 PS - Loss of power issue Reply with quote

Hi,

Guys have been driving Nissan Terrano 110 PS since more than 3 years and it used to run like charm.
From October 2017, I am facing some issues which are bothering me a lot!
When I used to drive the car, I started noticing the lose of power for a second or two from October, especially in 2nd and 3rd gear. The feeling was as if fuel supply was cut off for a brief second. After a few days, electric malfunction light came up for few seconds (and then went off) and I gave it you Surya Nissan. They promptly returned it saying that they did not find any error in diagnostic tool.
After a week, STOP ENGINE light came up for few seconds and again gave it to Surya Nissan. This time also they promptly returned it saying that they did not find any error in diagnostic tool.
There was no malfunction light anymore for 2 weeks. After that while driving in highway, STOP ENGINE light came up again which did not go off and after taking it to a local service station, it broke down completely and did not start. This time in the diagnostic tool, CYCLE 2 INJECTOR was shown as faulty.
The car was handed back to Surya Nissan and they confirmed the same error code. The fuel injector was replaced which cost a lot.
Now after the Car came back from the fuel injector replacement, I drove in peak traffic for around 40 KMS and again electric malfunction light came up. Actually, it came up 17 times by the time I reached home in a span of 10 KMs.
I again got the Car to Surya Nissan and they again mentioned that there is no error in diagnostic tool. I test drove with them in peak traffic and highway for quite a distance after that but no malfuction light came up. The fact is that they have done nothing after I gave the Car to them (except cleaning the fuel line) makes me nervous that the issue can come up again.
I am also not convinced that folks at Surya Nissan are competent and they just check for error code in diagnostic tool.
Could the experts here advice me regarding the issue and throw some light on the issue?

Any help will be apprecited.

I didn't find the right solution from the Internet.

References:
https://bit.ly/2I6iAWc
Business video studio

Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Nissan Path Forum Index -> General Automotive All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group