The Nissan Path Forum Index The Nissan Path
The World Wide Nissan Pathfinder Owner's Forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Use Google to search TheNissanPath forums ->
Problems installing New ECu

 
Post new topic   Reply to topic    The Nissan Path Forum Index -> 1996-2004 Pathfinder (R50)
View previous topic :: View next topic  
Author Message
rockypath



Joined: 08 Jul 2015
Posts: 2
Location: Denver co

PostPosted: Wed Jul 08, 2015 6:03 am    Post subject: Problems installing New ECu Reply with quote

Hello Pathfinder owners. I would appreciate any help.

I purchased a 2002 Nissan pathfinder that wasn't runnning. The problem was suppossedly the Idle speed control and the throttle control sensor.

I had the idle speed control and the throttle sensor replaced and the car started up! However, I had an idle problem.

I pulled out the ecu and found a blown chip. I had the computer refurbished and got it back. I installed the computer and the car started right away with no idle problems. Seemed to be running find.

I came back about 2 hours later to take a test run and tried to crank it and no start! It cranks but won't startup.

I tried to access the OBD error codes and my reader says GM-link failure.

I was able to access error codes using the flash system. Got these codes
1610
1615

I tried to reset the ECU but it is a no go.

Battery is currently disconnected for 24 hours to attempt ecu reset.

Anyone else had this problem?

Thanks for any help!
Back to top
View user's profile Send private message
rockypath



Joined: 08 Jul 2015
Posts: 2
Location: Denver co

PostPosted: Wed Jul 08, 2015 7:44 am    Post subject: Reply with quote

OK Problem Solved!

I have several great pieces of information to add they may help others.

1) 1615 is a key error code. If you put the wrong key in or if you put a damaged new/unprogrammed key in, you will get this error. The car will initiate a car lock and it will not start.

I put the key to my Toyota in there by accident and this locked it.

I unplugged the battery for 30 minutes and this fixed the problem.

2) The OBD reader will still not read. I am not sure if my reader is too old or if there is a true problem with the link. Some say that there may be a blown fuse not allowing the ready to function, but I cannot find any blown fuses in my box under the hood or inside the car.

3) The instructions for pulling up the error codes without a reader totally worked. Its is a little tedious but i did get them right and it led me right to the problem. Here is how to retrieve codes without an OBD reader:

************************************************************

To take a reading without using an OBD II reader, you can do this:

Note: Familiarize yourself with the entire procedure before attempting. A pen, paper, and stop watch will be helpful.

1. Put the car into “ON” without the engine started (hit the ignition button twice without having your foot on the brake)

2. Wait 3 seconds for the car to do a systems check (you know this is done when all the lights except your service engine light go off)

3. Do 5 full accelerator press and releases in 5 seconds (floor your car 5 times in 5 seconds)

4. Wait 7 seconds.

5. Floor the accelerator again, and hold it there for 10 seconds (approx).Your service engine light will turn off.

6. When the light turns off, take your foot off the pedal, and get ready to count.

At this point, the service engine light will start blinking.It will give you a 4 digit code – the first number will flash slowly, followed by a slight pause, the next three numbers will flash quickly, all with a pause in the middle.10 flashes means a number “0.”So if your car blinked 10 times, then 4, then 4, then 2 again, you would have a code of “0442,” which is your gas cap thing.Other codes can be determined by looking at a OBD II code reference sheet.
***********************************************************

3) The Throttle/idle speed control valve repair seems to have worked. The original went bad shorting out the ECU. If you replace the throttle control, be sure to replace the throttle sensor and the ecu or you will be shorting out the computer again.

I hope this helps someone!

Rod
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Nissan Path Forum Index -> 1996-2004 Pathfinder (R50) All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group