Airbag light started flashing

Topics related to Lights, Radio, Stereo, Headunits, Alternators...

Moderator: volvite

User avatar
McMac
Posts: 36
Joined: Wed Jan 14, 2015 7:47 pm
Location: Washington State

Airbag light started flashing

Postby McMac » Wed Feb 19, 2020 4:58 pm

Driving on freeway and airbag light just started flashing. There has been no electrical work at all (in more than a year) and it's been driven very little lately. Car was restarted a few times but it continued to blink. I used the procedure in an old thread to reset it, which worked. I'll see if it comes on again.

After poking around online, I found a group of Pathfinder owners complaining of this and several said there was a problem with the horn not working at the same time after the light started blinking (this was also mentioned in this forum https://www.thenissanpath.com/viewtopic.php?t=307 as being caused by using the horn). I couldn't find anything else posted here. They also referenced a recall and claimed that each of their VIN's were not covered under that recall, and that Nissan would not tell them which VIN's were covered. "The manufacturer was contacted by the dealer who stated that the vehicle was not included in NHTSA campaign number: 08v690000 (air bags)."

I also found TSB #NTB-08-055-A from January 2014 with a NHTSA TSB #10025522. It's for the front airbags sensor/control module.

Thoughts anyone?

Thank you.
Last edited by McMac on Thu Mar 05, 2020 5:48 pm, edited 1 time in total.


User avatar
disallow
Site Admin
Posts: 2801
Joined: Wed Aug 13, 2008 9:02 am
Location: Winnipeg, Canada

Postby disallow » Wed Feb 19, 2020 8:39 pm

This happens in my 05, usually when the wife is trying to help the kids with something in the back, and is crawling around and all over the front seat. Enough conflicting signals from her seat sensor, and the airbags go into 'safe mode' and the light starts blinking.

The only way to get rid of it is to clear the error code with a code reader.

Or do what you did. :)

Interesting research. I suppose you can't rule out a wiring issue of some sort. Let us know if it comes back!

User avatar
smj999smj
Site Admin
Posts: 5714
Joined: Sun Jan 22, 2012 11:13 pm
Location: Prospect, VA

Postby smj999smj » Sat Feb 22, 2020 3:41 am

First, go to Nissan's website and use their recall checker to make sure there are no open recalls that are applicable to your problem; you could call your dealer or Nissan's customer hotline @ 1-800-NISSAN-1. You will need your VIN #. If there is a recall that is open and applies to the air bag system, contact your Nissan dealer to have it fixed.

If there are no recalls open, look at the flashing pattern of the air bag warning light. If there is long and short flashes of any pattern, there is a stored code that will need to be accessed using a capable scan tool. If the flashes are all the same length (approx. 1/2 second, on/off/on/off), then it is in present diagnostic mode. In this case, try this procedure:

https://www.youtube.com/watch?v=1kG7aeTVkdw

User avatar
McMac
Posts: 36
Joined: Wed Jan 14, 2015 7:47 pm
Location: Washington State

Postby McMac » Sat Feb 22, 2020 3:11 pm

I did take smj999smj's advice and checked for recalls. There is a recall for the crash zone sensor for the airbags, but is only for vehicles in high road salt usage states (long list). Other states got a warranty extension to 10 years. My VIN showed nothing.

disallow- It's good to know that there are other things which might trip it.

I used that Youtube procedure to reset it and I've driven it a couple of times. It's stayed off so we'll see. It was a steady 1/2 second on/off blink.

If it comes on again, it's off to the dealership and I'll post any news from them.

Thanks all!

User avatar
McMac
Posts: 36
Joined: Wed Jan 14, 2015 7:47 pm
Location: Washington State

Postby McMac » Thu Mar 05, 2020 5:26 pm

Update- After clearing the code, it tripped again for the second time 2 days ago. I did clear it a second time and called the dealership and spoke with the service advisor who knows this car. He said they've not really seen problems with the airbags or the control units. Most often he said it's the shielded wiring bundle which connects all the goodies in the steering wheel (that would also explain the horn problems others reported as causing the light to trip), but of course won't know until it trips again and they can read the code. Anyway, since it's happened twice I'm assuming it'll happen again. Next time I'll not clear it and have them look at it and will post what they find.

User avatar
Swerve
Posts: 43
Joined: Thu Aug 13, 2009 11:03 am
Location: Coquitlam BC

Postby Swerve » Thu Apr 09, 2020 12:09 pm

I have a steady blinking airbag light. It was taken in by the previous owner at 120k KM's/ 75k miles, scanned and found to be a faulty 'spiral cable' which is in the steering wheel and had a $650CAD parts and labour estimate. I will be having this rechecked and done the next time it goes in for anything.

User avatar
McMac
Posts: 36
Joined: Wed Jan 14, 2015 7:47 pm
Location: Washington State

Postby McMac » Fri Apr 17, 2020 1:01 pm

Thanks for the info Swerve. After things calm down a bit, I'll plan to take it in and get it fixed. Will post what they find. If it is that cable- kind of sounds like it from the various sources- I'll know the ballpark dollar amount.

User avatar
McMac
Posts: 36
Joined: Wed Jan 14, 2015 7:47 pm
Location: Washington State

Re: Airbag light started flashing

Postby McMac » Wed Jun 10, 2020 1:18 pm

The airbag light was coming on more frequently, so I took it to the dealership. The code it pulled up did show the spiral cable was bad. All good after about $600 out the door.

User avatar
Swerve
Posts: 43
Joined: Thu Aug 13, 2009 11:03 am
Location: Coquitlam BC

Re: Airbag light started flashing

Postby Swerve » Wed Jun 17, 2020 9:18 am

Good to hear. For the benefit of others who also may encounter this, attached is the part we had swapped. Notice that it’s a big assembly behind the steering wheel airbag and it includes the stalks! It doesn’t come separate, you can get the lights/turn signals stalk and the other stalk separately but not the middle “spiral cable” part, only as an assembly.

Also on mine the radio volume and track selector switches intermittently worked or not from one minute to the next, where I just adjusted that directly on the radio itself. Replacing this assembly cured this issue for me as well. Everything is perfect now.
Attachments
B431E763-4093-4BDE-909C-59B89EF7F110.jpeg
4DFBDF82-63AA-4645-9A4A-B48C8EDCFD13.jpeg


Return to “R51 Electrical”